Page MenuHome

Blender 2.8 Crash in workbench with matcap.
Closed, ResolvedPublic

Description

System Information
Windows 10, GeForce GTX 1060 6GB/PCIe/SSE2

Blender Version
Broken: (Blender 2.80 (sub 34), hash: 26b1aa99436)

Short description of error
In Workbench engine, when trying to view in Render mode, Blender Crashes

Exact steps for others to reproduce the error

  1. Open Blender
  2. Create a Cube
  3. Go to Render Tab
  4. Select Workbench
  5. Select MatCap
  6. Select A matcap .
  7. Press Rendered up in the viewport .
  8. Get Crash

I've uploaded a animated gif with the steps .


Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Can confirm, complains about garbled wpd->composite_sh->interface

1  GPU_shaderinterface_ubo       gpu_shader_interface.c 336  0x27ad96c 
2  GPU_shader_get_uniform_block  gpu_shader.c           573  0x27ac51b 
3  drw_shgroup_init              draw_manager_data.c    633  0x27eab87 
4  DRW_shgroup_create            draw_manager_data.c    894  0x27eb8f4 
5  workbench_deferred_cache_init workbench_deferred.c   599  0x28689b2 
6  workbench_solid_cache_init    solid_mode.c           49   0x282e974 
7  drw_engines_cache_init        draw_manager.c         967  0x27e474a

@Clément Foucault (fclem), could it possibly be just P840? (fixes it for me...)

Philipp Oeser (lichtwerk) closed this task as Resolved.Nov 28 2018, 9:55 AM

@Clément Foucault (fclem): nvm, for some reason I cannot reproduce anymore.
I guess rB1d4ad6819857 fixed this as well [and there was just some issue with rebuilding that on my side...]

So @Catalin (giakaama), this is probably fixed by above commit, could you check latest buildbot build?
Closing (but feel free to reopen if issues persist)

@Clément Foucault (fclem) Downloading the latest now, I'll check if it still happening :) .

Thanx guys for your hard work .