Page MenuHome

Spin tool top bar settings don't apply
Closed, ResolvedPublic

Description

System Information:
CPU: Ryzen 5 2600
GPU: RX 570 4GB
OS: Windows 10 Home

Blender Version
Broken: Blender 2.8 Beta 26d5a3625ed

Short description of error:
The spin tool and spin tool duplicate in edit mode ignore step settings changes in the top bar.

Exact steps for others to reproduce the error:

  1. Open Blender and switch to the 3D viewport.
  2. Create an object if there isn't one already.
  3. Enter edit mode on the object.
  4. From the tool bar, select spin or spin duplicate.
  5. In the top bar, adjust the step settings for the spin tool. I'd recommend changing the steps to 1.
  6. Use the gizmo on your object and notice that it's still spinning with nine steps (or the same number you set in the redo panel the last time you used the tool).

Event Timeline

William Reynish (billreynish) closed this task as Invalid.

Not a bug. Use the panel in the bottom to adjust.

Alaska (Alaska) reopened this task as Open.EditedNov 29 2018, 11:03 PM

@William Reynish (billreynish)
I would consider this a bug as every other tool (take the bevel tool for example) respects edits made in the top bar prior to the tools use. And if this is working as expected, then why is the steps option included in the top bar if it does nothing?

This issue still exists today: The Spin tool Steps property doesn't work when set from the top bar.

William Reynish (billreynish) triaged this task as Confirmed, Medium priority.Jan 22 2019, 1:14 PM