Page MenuHome

Voronoi(Cells) does not work on eevee
Open, IncompletePublic

Description

System Information
Operating system: Windows Version - Windows 10 (64 bit)
Graphics card:

Graphics Card Manufacturer - Powered by AMD
Graphics Chipset - Radeon(TM) 540 Graphics
Device ID - 699F
Vendor ID - 1002
SubSystem ID - C162
SubSystem Vendor ID - 144D
Revision ID - C3
Bus Type - PCI Express 3.0
Current Bus Settings - PCI Express 3.0 x4
BIOS Version - 015.050.002.001
BIOS Part Number - BR21398.018
BIOS Date - 2017/11/01 01:27
Memory Size - 2048 MB
Memory Type - GDDR5
Memory Clock - 1500 MHz
Core Clock - 1124 MHz
Total Memory Bandwidth - 48 GByte/s
Memory Bit Rate - 6.00 Gbps
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0002

Radeon Software Version - 17.12
Radeon Software Edition - Adrenalin
System Memory - 16 GB
CPU Type - Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz
Radeon Settings Version - 2018.0503.2337.40688
Driver Packaging Version - 17.50.36-180503a-328933C-Samsung
Provider - Advanced Micro Devices, Inc.
2D Driver Version - 8.1.1.1634
Direct3D® Version - 9.14.10.01316
OpenGL® Version - 6.14.10.13507
OpenCL™ Version - 23.20.15036.0
AMD Mantle Version - Not Available
AMD Mantle API Version - Not Available
AMD Audio Driver Version - Not Available
Vulkan™ Driver Version - 2.0.18
Vulkan™ API Version - 1.1.70

Blender Version
Broken:
version: 2.80 (sub 35), branch: blender2.8, commit date: 2018-11-30 00:46, hash: 4c31bed6b46, type: Release
build date: 29/11/2018, 17:09

Short description of error
Simple texture mapping produces random dithering. In cycles it works. Intensity works.

Exact steps for others to reproduce the error
Assign voronoi to the cube, choose Cells.

Details

Type
Bug

Event Timeline

Fabio Roldan (fabioroldan) renamed this task from Voronoi does not work on eevee to Voronoi(Cells) does not work on eevee.Sun, Dec 2, 1:24 AM
Fabio Roldan (fabioroldan) updated the task description. (Show Details)
Stephen Swaney (stiv) triaged this task as Incomplete priority.Mon, Dec 3, 8:50 PM

Seems to be working with a build from 2-Dec. You might try a newer build.
Please attach a .blend so we can see your setup.

Stephen Swaney (stiv) raised the priority of this task from Incomplete to Needs Triage.Thu, Dec 6, 1:57 PM

Thanks. Don't see anything funny about the setup.
Using daily build from 5-Dec, I'm seeing the colored cells.
Can't reproduce on Linux.

Mine is much prettier!
I wonder if it is something to do with EVEE vs Radeon graphics.
You checked with a newer build?

Besides checking newer blender builds, I would suggest getting the latest drivers for your GPU: https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-540

Sebastian Parborg (zeddb) triaged this task as Incomplete priority.Mon, Dec 10, 12:55 PM

I update blender almost every day, and I have the latest drivers because I have an automatic driver updater. In my workstation it works but in my personal laptop that sometimes I use to work not.

Are you sure it is the latest driver version?

If the one you posted here is true, then the driver is a year old. (They use Year.Month as the version number)

In your case it seems to be 17.12, that is the 2017 december release. The link I gave you suggest that the latest driver available for that card is from december of this year. So 18.12.