Page MenuHome

Crash on switching to material tab in properties editor
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 64-bit
Graphics card: MSI NVidia RTX 2070 8GB

Blender Version
Broken: Blender 2.80 beta, 925380050d0, 2018-12-02, from blender.org

Short description of error
Blender crashes on switching to materials tab after .blend loaded

Exact steps for others to reproduce the error

  1. Load .blend
  2. Switch to materials tab in properties editor

.blend was created by loading a glTF model exported from Substance Painter.

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) triaged this task as Confirmed, Medium priority.Dec 2 2018, 4:25 PM

There is an Assert.

23: BLI_system_backtrace - 0x2F543180
22: mesh_render_data_create_ex - 0x2EA3D0F0
21: DRW_mesh_batch_cache_get_surface_shaded - 0x2EA393C0
20: DRW_cache_mesh_surface_shaded_get - 0x2EA7D410
19: DRW_cache_object_surface_material_get - 0x2EA72490
18: EEVEE_materials_cache_populate - 0x2EAC7750
17: EEVEE_render_cache - 0x2EAE1BC0
16: DRW_render_object_iter - 0x2EA30F70
15: eevee_render_to_image - 0x2EAC40A0
14: DRW_render_to_image - 0x2EA30A60
13: RE_engine_render - 0x2E44E2B0
12: do_render_3d - 0x2E462AB0
11: RE_PreviewRender - 0x2E4602A0
10: shader_preview_render - 0x2E2EC990
9: shader_preview_startjob - 0x2E2ECEC0
8: icon_preview_startjob - 0x2E2ED510
BLI_assert failed: c:\myblender\blenderdev\blender\source\blender\draw\intern\draw_cache_impl_mesh.c:907, mesh_render_data_create_ex(), at 'CustomData_number_of_layers(&rdata->cd.output.ldata, CD_TANGENT) == rdata->cd.layers.tangent_len'

@Clément Foucault (fclem) I think this one is for you.

I'm running into the same issue. This is only happening with glTF models. Blender will crash after importing the attached .glb file and switching to the materials tab. The .glb file was created by exporting the attached .blend file from Blender. I'm running Blender version 2.80, 96f762500ef9, 2019-01-07 00:16. Windows 10 with an NVIDIA GeForce GTX 960.



I can't reproduce this bug, neither the assert in last master. Is this still crashing for you with last buildbot version? https://builder.blender.org/download/?hc_location=ufi

Seems to be working with the last buildbot version.

Ulysse Martin (youle) closed this task as Resolved.Feb 12 2019, 5:11 PM
Ulysse Martin (youle) claimed this task.

Oh I didn't see that I can change status. I try to change the status to resolved then. Thanks for the feedback