Page MenuHome

Imported key configurations are missing the preference menu
Closed, ArchivedPublic

Description

System Information:
CPU: Ryzen 5 2600
GPU: RX 570 4GB
OS: Windows 10 Home

Blender Version:
Broken: Blender 2.8 Beta 925380050d0

Short description of error:
Exported key configurations don't appear to save the "preferences" tab and thus when imported are missing the "preference" tab and ignores information that should of been saved when exporting the key configuration.

Exact steps for others to reproduce the error:

  1. Open user preferences (Edit>Preferences).
  2. In the user preferences change to the input tab, notice the preference tab.

  1. Export your key configuration using the "Export Key Configuration" button and re-important it using the "Import Key Configuration" button.
  2. Notice that the preference tab is missing. It also appears that any settings in the preference tab is ignored (presumably because they don't exist in the original file) and the preferences from the previously selected keyboard configuration will be used instead. (You may also notice that the bottom bar is now on the top, this is a bug for a different report if you wish to make it)

Details

Type
Bug

Event Timeline

Alaska (Alaska) updated the task description. (Show Details)
Alaska (Alaska) updated the task description. (Show Details)
Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

This is by design, only for the builtin keymap do we support these kinds of settings. For arbitrary user-defined keymaps we can't assume anything about how shortcuts are mapped in order to change them.

Saved key configurations have those settings baked in.