Page MenuHome

Mouse wheel not responding when under side panels/tool shelf
Closed, ArchivedPublic

Description

System Information
Operating system:
Windows 10

Graphics card:
GeForce GTX 745/PCIe/SSE2
NVIDIA Corporation
4.5.0 NVIDIA 388.13

Blender Version
Broken:
version: 2.80 (sub 35), branch: blender2.8, commit date: 2018-12-03 00:27, hash: a205493426b, type: Release
build date: 02/12/2018, 17:01

Short description of error
Mouse wheel not responding when under side panels/tool shelf

Exact steps for others to reproduce the error

  1. open default
  2. in the center of the viewport, roll mouse wheel to zoom in and out or hold down mouse wheel to rotate. All is as expected.
  3. move cursor horizontally to left or right, into a CLEAR space, UNDER the Tool panel (T) or Side panel (N).
  4. roll mouse wheel and the zoom does NOT function; hold down mouse wheel and drag to rotate also NOT functioning.

However, holding a modifier key (Shift, Control or Alt) while operating the mouse wheel DOES work in the otherwise DEAD space under the toolbar/side panel.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed priority.Thu, Dec 6, 5:14 PM

The scroll wheel does no work in those cases as it is used to scroll the menus if the can not fit in the screen space. The spaces on the side (under the side and tool panel) belongs to them. You can just see that because the background color for those panels are set to be fully transparent by default.

@Brecht Van Lommel (brecht) I'm guessing this is a WONTFIX at the moment?

Brecht Van Lommel (brecht) closed this task as Archived.Thu, Dec 6, 5:16 PM

We do intend to fix this, by making the region smaller depending on the context. For now we don't consider it a bug though.