Page MenuHome

Displacement map in Cycles fails
Closed, ArchivedPublic

Description

Operating system: win 7 64bit
Graphics card: nvidia gtx980 + gtx780

Blender Version
Broken:
blender2.8, commit date: 2018-12-04 15:40, hash: be91d4ef957
Worked: 2.79b

Short description of error
the displacemente map fails in rendered view and rendering
It works well in lookdev

Exact steps for others to reproduce the error
Add suzanne
add wave texture in displacement map
cycles render -> wrong result

https://www.dropbox.com/s/k0k8bsf3bxvvw6o/displacement.blend?dl=0

Details

Type
Bug

Event Timeline

I'm not sure how it should look like. @Brecht Van Lommel (brecht)

I guess in Lookdev mode bump mapping is used while in the render, only the existing vertices are moved. Maybe the actual problem is that the subdivision modifier does not seem to do anything?

Brecht Van Lommel (brecht) closed this task as Archived.Wed, Dec 5, 2:12 PM
Brecht Van Lommel (brecht) claimed this task.

Cycles does actual displacement, while EEVEE does not support it yet. For good looking displacement you'll need a few more subdivision levels though.

If you only want bump mapping in Cycles, you can change it the Material properties > Settings > Surface panel.

@Jacques Lucke (JacquesLucke), I guess you have WITH_OPENSUBDIV disabled in CMake?

Oh oops, yes that subdiv thing was my fault. thx

Sorry, maybe I did not understand the discussion.
when the version of blender 2.80 is fixed, will I have the same result as a 2.79 blender?
Currently (build 2018-12-06 00:27, hash: 74db65e5424) the result is completely different as you can see from this screenshoot


this is the blend file

tnx in advance

In 2.8 you need to use a Displacement node. If you load that 2.79b file in 2.8, it will be automatically inserted.
https://wiki.blender.org/wiki/Reference/Release_Notes/2.80/Cycles#Subdivision_and_Displacement

When using displacement in materials, a new Displacement node must now be used. This node will be automatically inserted into existing .blend files. The reason for this change is to support vector displacement, and to make it easier to tweak the displacement scale and midlevel. (4a5ee1a) (b129ea8)

thank you, you are an exceptional team !!!