Page MenuHome

CTRL Click to Isolate can not un-isolate (it's not a toggle)
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GeForce 1080

Blender Version
Broken:
Blender 2.8
2018-12-07 04:54
Hash: 606223f6a61

Short description of error

CTRL+Clicking the eyeball in the outliner hides everything tells you that it will isolate the objection, collection, etc. It does do this (basically hiding everything else in the scene) but there's no clear way to un-isolate. So when a user does this, it becomes a destructive process, especially on scenes with hundreds of objects.

Currently this method of isolating objects simply does a Hide Unselected operation. And of course, this can be undone with Show Hidden.

My recommendation is to change the CTRL+Click on the Eyeball to a toggle for Local mode. Local Mode has the same basic effect, but it's a toggle. Furthermore, Maya and other programs that have an Isolate mode work the same as Blender's Local mode. So using the Local mode toggle when you CTRL+Click the eyeball would both fix this issue and make this more consistent with other applications.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.Dec 7 2018, 3:10 PM
Brecht Van Lommel (brecht) claimed this task.

It's a good suggestion, we already planned to add this, but it's not a bug.