Page MenuHome

Recognizing too much GPU's
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10 Pro
Graphics card: 4x AMD Pro Duo (Polaris)

Blender Version
Broken: 2.79b release, blender2.8 beta

Short description of error
Blender recognizes twice as many GPU's as are in the System.
While trying to render any scene in Cycles with the GPU's, Blender keeps crashing. In the System User Preferences by Cycles Compute Device, OpenCL, there show 16 Graphicscards up. By deactivating the last 8 GPU's the System doesn't crash and renders with all GPU's.

Exact steps for others to reproduce the error
Based on the default startup blender automatically recognizes too much GPU's.

Details

Type
Bug

Event Timeline

@Lukas Stockner (lukasstockner97), looks like you did the last larger refactor in that area. Do you know what is going on?

I had the exact same issue. Two RX 570's reported and Blender crashes if the "false" GPU is enabled while rendering. Doing a clean install of the drivers fixed it for me.

@Alaska (Alaska) a clean install was made multiple times, with no difference on the number of recognized GPU's

Can you try running blender with the arguments -b --debug-cycles --python-expr "import _cycles; print(_cycles.available_devices())" from the command line and posting the output here?

It might also be caused by saved user preferences, try running with --factory-startup and checking if the problem is still there.

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.Dec 17 2018, 4:30 PM

@Lukas Stockner (lukasstockner97) I tried the factory startup with no result.
I'm sorry if i failed to see the output, but when i start Blender with the given arguments and start the rendering Blender crashes and doesn't show anyting in the command line (no output).

Philipp Oeser (lichtwerk) closed this task as Archived.Mar 19 2019, 9:36 AM
Philipp Oeser (lichtwerk) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.