Page MenuHome

World surface shading renders black in Cycles
Closed, ResolvedPublic

Description

System Information
Operating system: Windows
Graphics card: GTX 960

Blender Version
Broken: 2.80 9149e894210

Short description of error
Regardless of the RGB value or image piped into the Background shader, the world surface is rendered as a constant black.

Exact steps for others to reproduce the error

  1. Attach a Background shader to the world and change its colour or image.
  2. Witness the magic of nothing but empty darkness.

Details

Type
Bug

Event Timeline

Sam Van Hulle (sam_vh) renamed this task from World surface shading renders black to World surface shading renders black in Cycles.
Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

I can't reproduce this, as long as the Film > Transparent is off, I see a background color.

In my case, both the background colour and the shading are pure black.
Attached is a screenshot of rendered mode with film transparency and the problem.


This is at the studio in Linux build 08e6948da50, so it does have the same problem as my 9149e894210 build on Windows at home.
It can't really be a driver thing afaik, since this is not using GPU rendering.

Sam Van Hulle (sam_vh) closed this task as Resolved.Dec 18 2018, 11:50 AM
Sam Van Hulle (sam_vh) claimed this task.

Aaaaand my bad, little oversight that was completely my own fault.