Page MenuHome

Blender 2.8: Applying more than one material on a mesh object Blender instantly crashes (Build: a2466049376 windows64)
Closed, ResolvedPublic

Description

System Information

Operating system: Windows 10, 64 bit, 16 gb ram ddr3
Graphics card: Nvidia Geforce 1070, 8gb vram

Blender Version

Date: 2018-12-19 08:13
HASH: a2466049376
Blender 2.8

Broken:

version: 2.80 (sub 37), branch: blender2.8, commit date: 2018-12-13 01:30, hash: 7d4d9e9dbd3, type: Release
build date: 12/12/2018, 18:59

Tested and replicated the bug on these versions:

blender 2.80.0 a2466049376 windows64

blender 2.80.0 fd42fe66161 windows64

Short description of error

Upon applying more than one material on a mesh object using materials tab in the properties window will cause instant crash of Blender.
Video of the bug is attached to this message, also I've attached the blend file used in the video.
Also, I've generated two system info txt files, one is generated via Blender and another one is generated by msinfo32 in Windows.

Thank you guys for all your amazing work!

(P.S. Sorry for scary desktop wallpapers in the video, it's a slideshow of thousands of images in the folder Windows decided to grab those during the video...)

Exact steps for others to reproduce the error

  1. Open blender
  2. Create mesh material in the viewport
  3. Enter edit mode
  4. Choose faces of the mesh
  5. Open Material tab in the properties window
  6. Create two materials and assign them on different faces of a mesh object.
  7. Crash all the time you attempt to do that.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can not reproduce this issue.

In the off chance that this is a GPU related issue, could you update your nvidia drivers to the latest version? https://www.nvidia.com/Download/index.aspx?lang=en-us

If that doesn't help, could you run blender with "--debug-gpu" and attach the output?
You can also try to run blender with "--debug-gpu-force-workarounds" and see if that helps too.

Hi! Thank you for your reply! I've done a clean install of the latest Nvidia drivers on my system and rebooted the system. Then tried again and stumbled across the same issue, it crashes upon adding more than one material and assigning it to face of a mesh, or sometimes when you create a new material. I've started blender through cmd line using both "--debug-gpu" and "--debug-gpu-force-workarounds" commands, but it crashed again. I've recorded a video of the crash and also saved the error output from the cmd window into two separate text files.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Normal.

@Clément Foucault (fclem) don't know if this is your area, but because I can't reproduce this, I'm guessing it is GPU related.

That is such a random bug... It works on certain types of geometry in the scene, for example, if I create a new scene with a cube and then try applying materials to it it will work fine. But when I work in that specific scene that I've originally attached and apply materials on certain objects it gives the error always resulting to EXCEPTION_ACCESS_VIOLATION and the same address in the cmd log. I've made another video of the bug, I apply multiple materials on one object successfully, but when I apply multiple materials on other objects it crashes. I've tried also clearing all data from the objects, but it still crashes in the same fashion.

I've created a scene with multiple objects and crazy amount of materials and applied it to different objects, and it works fine. For some reason, the bug appears to be present in that particular blend file, I don't know what is the cause (most probably object refers to a restricted GPU memory address when applying several materials for some reason), I guess I'll just create a new scene and import mesh from that blend file or export mesh and import to a new scene, maybe it will fix the problem.

Hmm, no, it appears to be super random and present basically in all my blender scenes, where I have worked for an extensive period of time editing the mesh... I guess it is GPU related, but I don't know exactly how to fix this =((...

Finally! I have gotten to the bottom of this! The problem occurs ONLY with the mesh that has mirror modifier assigned to it!

Exact steps to reproduce the problem:

  1. Open blender, create a new scene
  2. Delete half of the cube, create empty and apply mirror modifier to a cube with an empty as a mirror target
  3. Open Materials tab in properties
  4. Create couple of materials with different colors
  5. Assign different materials to different faces
  6. Crash

Works 100 % of the cases (At least for me)! For now, I just apply mirror modifier before applying materials as a workaround. But my guess is that it is not a GPU issue, as it has been assumed before, It has something to do with the simultaneous work of Materials tab and symmetry modifier (possibly multiple modifiers, I didn't check array and etc) applied to a mesh object!

Here's a video log of the exact steps to replicate the problem:

Nope, still can't reproduce this on my end. :c

That's strange, =(. I have this bug all the time with mirror modifier. It's also important to change the base color of materials and apply them to different faces, when they are identical in parameters then it won't crash, as soon as you change base color when the mirror modifier is applied it does crash.

UPDATE: No, actually you don't even have to change the color, just have mirror modifier applied so that the mesh is visibly mirrored in the viewport and apply multiple materials of faces and this will result into crashes all the time.
That's super weird O_o

Unfortunately I'm also not able to reproduce this bug..

@Chingiz Jumagulov (Krayzmond) Do you have access to some other computer where you can test this?

Could you try resetting to factory defaults just in case that help? I doubt it, but it can't hurt to try...

Wow! I was in a doubt it would help, but resetting to factory defaults did help and the bug is gone like it never been there before! That is strange =)).

Sebastian Parborg (zeddb) closed this task as Resolved.Dec 20 2018, 5:00 PM
Sebastian Parborg (zeddb) removed Clément Foucault (fclem) as the assignee of this task.

Let us know if you ever figure out what made it behave this way. It seems to be settings related or something then.

I need to fix this bug to finish a project. resetting to factory only fix if you want to start another project.
Some ideas to fix this?

You have to figure out what is causing this by finding what is different from the factory settings.

It seems to only happen in the eevee rendering mode. I switched to cycles and it works perfectly for the materials tap. Then I went back to eevee and everything is fine.