Page MenuHome

Object wireframe clips through mesh when working at smaller scales than default
Closed, ResolvedPublic

Description

System Information
Operating system: Kubuntu 18.10, Windows 10
Graphics card: 1080TI

Blender Version
Broken: 2.80, 6d89337257b6, blender2.7, 2018-12-24 14:03

Short description of error
When working at smaller scales, the default clipping plane is too far away and must be reduced. Mesh wireframes do not appear to take this new clipping plane into consideration and cause backface wires display through the mesh when zoomed out. (See video below repro steps)
It does not happen while the viewport is rotating, which leads me to believe this is related to wireframe anti-aliasing but I could not test it with AA disabled because unlike UI text there's no way to disable it (HINT HINT)

Exact steps for others to reproduce the error

  1. Set the scene units to Centimeters
  2. Subdivide the default cube a few times to create some geometry to work with
  3. Set the cube's dimensions to 10cm and apply the scale
  4. Change the near clipping plane to .01mm
  5. Observe the backface wires showing through the mesh.
  6. Rotate the viewport and note that the backface wires disappear as long as the viewport is moving
  7. Change the near clipping plane to 1mm
  8. Zoom in and out to see the effect increase and decrease in intensity, though noticeably less than when the near clipping plane was set to .01mm

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

This is sadly how clipping values work. Small clipping values will produce errors. There is no getting around that.

eldee smith (eldee) added a comment.EditedDec 31 2018, 5:03 PM

This is sadly how clipping values work. Small clipping values will produce errors. There is no getting around that.

Wait, what? I dont' mean to offend, but did you even watch my demonstration? The artifacts disappear while the viewport is being rotated, so *clearly* something else is going on. It has nothing to do with normal geometry clipping- it's only happening on wireframes while the viewport is stationary.

It's a little frustrating to spend the time making detailed bug reports and coming up with clear repro steps if they're not even looked at.

edit: look at timecode 1:00 in my video

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

Sorry, you are right. I should have read and watched the bug report more carefully.
There does indeed seem to be something going on with the static edge drawing that doesn't happen when moving around.

No worries, thanks for taking another look!

Clément Foucault (fclem) closed this task as Resolved.Feb 5 2019, 7:06 PM

Fixed by commiting the refactor of edit mode drawing. rB86193d25dbe5

Is this fix in the latest build because I'm still seeing an x-ray view of edges in orthographic mode with x-ray turned off?