Page MenuHome

EEVEE - Distance Bump/Normal's Spec dancing - animated camera
Closed, ResolvedPublic

Description

System Information
Operating system: Both Linux and Windows
Graphics card: AMD R9 390

Blender Version
blender-2.80.0-git.7c438e5366b2 (and 2.8 before)

Short description of error
both render and viewport have dancing specularity on bump/normal maps and the edges are so jagged

Exact steps for others to reproduce the error
add a bump or normal map to a plane and move camera (or viewport), uploaded a sample scene

Details

Type
Bug

Event Timeline

it is specially visible when moving vertically

I hope they fix this. The Bump node basically causes bumps at half the resolution of the render. My understanding is that it uses the difference of value between adjacent pixels and that's why it's half res. It was also like that in 2.7's material viewport, but I think Eevee needs it if it's going to be used in final production. Maybe internally sampling the bump texture at double the render resolution, or with a jittered approach for each sample. I had to render at 4k so it's less noticeable 😂, luckily Eevee is fast. Btw, actual normal textures with a Normal map node, like tangent space normals, look fine and fullres.

The Bump node basically causes bumps at half the resolution of the render.

Yep, that's known limitation. Explanation:

As of now, bump mapping is supported using OpenGL derivatives which are the same for each block of 2x2 pixels. This means the bump output value will appear pixelated. It is recommended to use normal mapping instead.

If you absolutely need to render using Bump nodes, render at twice the target resolution and downscale the final output.

Source: https://docs.blender.org/manual/en/dev/render/eevee/limitations.html#materials

Possible duplicate of T58522

thank, yes seems normal map is way much better.

Ali Najafi (shylon) closed this task as Resolved.Dec 30 2018, 3:37 PM