Page MenuHome

G X and move results in crazy number in the position box.
Closed, InvalidPublic

Description

Linux Manjaro fully updated.
Nvidia 580 GTX
1,1 2019 64bit linux blender 2.8

new -> general
select default object (changed to a sphere for my system)
G ->X move backwards and at some point and it changes the numbers box goes from [x -418] to [-100000000000] or so. and then with more movement back starts with other numbers. When you come back it jumps right back to x -418 and at the same location of mouse movement. At is not always at -418 and I can reproduce the error on the Y axes as well. It also fails with two objects selected but it seems to happen at a lower number (-418 was with two objects).

Details

Type
Bug

Event Timeline

I reproduced the error in 2.79b also.

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

This is because it tries to track the movements to the mouse cursor. If you move the cursor to far up, the calculated transform location will almost be perpendicular to the X axis. So the transform value will jump to a really high number.
You can see that this is not a problem if you change to the top view and transform along the x axis.

It is still a BIG bug. I can position my model where it should be. Here is a video of the problem.

If you want to workaround this limitation, you can click and drag on the X location in the N-panel.

OK, thanks for your time!

Sorry this couldn't be solved in a better way.