Page MenuHome

Memory leak on fluid simulation
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
RAM: 16 GB
Graphics card: NVIDIA Geforce GTX 960m

Blender Version
Broken:
hash: 26d5a3625ed, blender2.8, 2018-11-29

Short description of error

  1. Fluid simulation takes lots of RAM (11 Gb) and it's very slow. But "Final Resolution" is set to 65. If I set "Final Resolution" to 90, Blender breakes.

The .blend file:

Exact steps for others to reproduce the error

  1. Run fluid simulation on Куб.001 (Cube.001)

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) renamed this task from Memory leak on fluid simulation AND Particle Info node doesn't work on Eevee to Memory leak on fluid simulation.

Please follow the bug submission guidelines:

If there are multiple bugs, make multiple bug reports.

But particle node support is not a bug, rather a documented limitation:
https://docs.blender.org/manual/en/dev/render/eevee/materials/nodes_support.html#input-nodes

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Are you sure you are not just running out of RAM? As you said it already take up a lot of RAM (and it is already a bit close to you total 16GB).
It is expected that high resolution fluid sims takes up a lot of ram and is very slow.

Do you get this problem with 2.79?

I tried in blender 2.79b and it took 1 GB for this simulation.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Confirmed, Medium.Jan 24 2019, 5:22 PM

Can you try the 2.79 build from here: https://builder.blender.org/download/ ?

I run out of memory in the latest 2.79 build too.
If you do not, could you provide the 2.79 file?

Sebastian Parborg (zeddb) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Jan 24 2019, 5:22 PM
Vitaly Egorov (vitos23) closed this task as Resolved.Jan 24 2019, 7:24 PM
Vitaly Egorov (vitos23) claimed this task.

So, I found out that in my simulation there were two objects with ~30000 faces. I tried replace them with spheres and everything worked perfectly. Thanks for help. But I have the question - how many RAM PC mast have for blender working perfectly? 32GB is enough?

So this didn't work in 2.79? If it takes a lot less ram, then you probably have found a problem.

RAM depends on what you are doing. If you really tried, you could do things that go over 32GB. But in most cases, that means that you have gone overkill on something.