Page MenuHome

Unable to Drag View in Movie Clip Editor
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Intel (R) HD Graphics 4000

Blender Version
Broken: 2.79b release, f4dc9f9d68b hash, 2018-03-22 14:10 date

Short description of error
Unable to click and drag clips in Movie Clip Editor to change view.

Exact steps for others to reproduce the error

  1. I followed the tutorial in this video: https://www.youtube.com/watch?v=EmzfaD6IgZ8 until it got to the point where I need to mask the can itself.
  2. I opened the Movie Clip Editor in one of my views
  3. I loaded my image files (.png)
  4. I zoomed in using my mouse wheel
  5. When I try to click and drag the clip as the instructor does in the video, I am unable to do so. Nothing happens at all.

I tried to see if there were any settings that were "locking" the image in place but there are none that I can see.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

So you have switched to mask mode and added a mask?

I can't reproduce this on my end. If I am in mask mode and have added a mask, I can add the mask points.

It doesn't matter whether I am in mask mode or not. I cannot click and drag the view to adjust it so I can apply a mask but not to the level of detail I need since I can't zoom in to what I'm seeing. When I zoom, it stays locked onto the center of the image and I can't drag the view up, down, left, or right. I tried reinstalling Blender but it didn't seem to change anything.

Does it happen with the 2.79 build from here? https://builder.blender.org/download/

If so could you perhaps make an idiot proof step by step guide on how to reproduce this?

Hello,

Yes, it happens on the 2.79 release. Just tried it. Here's the issue:

  1. Open Blender
  2. Switch to Video Editing view/workspace
  3. Change one of the views to Movie Clip Editor
  4. Load in ANYTHING...video, images, whatever...doesn't seem to matter
  5. Attempt to click and drag image/clip/whatever to adjust view by moving it left, right, up, or down. FAILS.

Using middle mouse button to move around works for me.

So just to be clear, you can't pan around the view with middle mouse button?

Bruce Gates (OpenDm) added a comment.EditedJan 25 2019, 2:54 PM

I think we're getting onto something here. I have no middle mouse button. Only left and right mouse buttons. I also have a scroll wheel. I've tried both LMB and RMB as well as BOTH at the same time

So you can't push down on the mouse wheel to make it click (that is the middle mouse button).

Sebastian, you sir are the MAN! Geez, I knew this was something ridiculous! Thank you SO much for your help, my friend!

Bruce Gates (OpenDm) closed this task as Resolved.Jan 25 2019, 2:58 PM