Page MenuHome

Blender 2.8 crashes on startup
Closed, ResolvedPublic

Description

System Information
MSI Prestige PE70 2QE Laptop
Operating system: Windows 8.1
Graphics card: Nvidia GeForce GTX 960M
CPU: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60Ghz
RAM: 8 GB

Blender Version
Broken: blender-2.80.0-git.91a155833e59-windows64 (09-01-2019)
Worked: 2.79b

Short description of error
Blender 2.8 closes at start-up.

The strange thing is, once in a while (approximately 1 out of 20) it will start and I can modelling for example works. But when I try to go into lookdev mode it usually shuts down anyway and the same thing with opening project files.
I am having the same problem for a month now with all the daily builds on my laptop. (The daily builds before that did work)
Blender 2.8 runs just fine on the desktop.

I tried the following:
Starting Blender via cmd
Starting Blender via cmd with --factory-startup
Starting Blender via cmd with --debug-gpu
Removing Blender 2.79b

Drivers are up-to-date.

Cmd reports:

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Does this still happen with the latest blender beta?

If so is there any improvement with --debug-gpu-force-workarounds ?

Thanks for the reply.

The latest build did improve it.
Blender doesn't crash upon startup anymore :)

However, it mostly still crashes when I try to do some simple tasks like adding a noise texture to the default cube.
I did try it with --debug-gpu-force-workarounds, it has about the same crash rate as using the blender.exe
I also removed the %appdata% which seemed to improved it too.

In the picture you can see some weird shading atrifacts. Mostly the cube remains totally black, or the whole viewport is black.
Sometimes it updates and the shading comes back.
This is mostly a first sign that Blender will crash when doing something like adding a noise texture.

It did the trick!

I thought my drivers where up to date, but I wasn't aware that only the drivers of the system were op to date.

So for people with the same problem, remove the Blender appdata and update drivers including the GPU driver.

Thanks for problem solving Sebastian!!

Sebastian Parborg (zeddb) claimed this task.

No problem :)