Page MenuHome

Creating a new image texture in shader editor does not appear among the texture slots
Confirmed, LowPublicBUG

Description

Windows 10 Pro 64bit, AMD Ryzen 5 2600, 16Gb RAM
NVidia GTX 1060 6Gb

Windows 10 Pro 64bit, AMD Ryzen 5 1600, 8Gb RAM
NVidia GTX 1050Ti 4 Gb

Blender 2.8 Beta 91a155833e59

If you are texture painting in one window and you modify the shader by adding/removing an image texture to it in another, it won't appear/disappear from the texture slot list until you change to edit mode (or anything else) and back. Another issue is that this way you can paint onto an image texture that is no more connected to the shader and it doesn't disappear even if you do the "edit mode and back" (TAB x2) trick.

Steps: Add an image texture to the shader in the attached file, connect to the roughness for example, create a new texture for. It won't be in the texture slots list. Now TAB x2 in the 3D view, slot appears. Paint on it, delete the node from the shader. It is still in the list. TAB x2. It is no more in the list, but the 3D view still shows the texture.

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from 90 to 50.
Brecht Van Lommel (brecht) changed the task status from Resolved to Unknown Status.Mar 7 2019, 7:43 PM
Brecht Van Lommel (brecht) lowered the priority of this task from 50 to Low.
Richard Antalik (ISS) closed this task as Resolved.Jan 22 2020, 6:57 PM
Richard Antalik (ISS) claimed this task.
Philipp Oeser (lichtwerk) reopened this task as Confirmed.Jan 22 2020, 7:03 PM

This is not resolved.
@Richard Antalik (ISS): have you actually checked this?

Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Bug".Jan 22 2020, 7:04 PM

@Richard Antalik (ISS) indeed the issue is still there. We should only close these reports without confirmation from users if you can guarantee it worked in the reported version (so you managed to reproduce it), but then not in the latest Blender.