Page MenuHome

Crash with Grease pencil
Closed, ResolvedPublic

Description

System Information
Operating system: Mac OS X 10.14.2
Graphics card:

Blender Version
Broken:
2.8 Beta, downloaded on 07.01.19

Short description of error
Blender crashes the moment I try to fill color on the GreasePencil

Exact steps for others to reproduce the error
I can draw and fill color as long as lines are all in the same layer. The moment, I create a new layer and click on fill color Blender Crashes.
It doesn't matter if the layer is below or above, clicking the fill crashes it immediatly

Herein attached a report as my computer produced and the attached blend file.
[[

| name ]]

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) triaged this task as Needs Information from User priority.Jan 12 2019, 8:44 AM
Antonio Vazquez (antoniov) claimed this task.

I cannot reproduce with the compilation of today. IIRC this bug was fixed yesttrday. Please, download the build of today and test again.

BTW: Testing your file, if you set a leak size of 35px, the fill will not be right, change to something like 3px.

I was having this issue on windows 7 64 bits. however I'm currently testing the following build and I can confirm this issue has been fixed.

version: 2.80 (sub 41), branch: master, commit date: 2019-01-14 19:48, hash: 84c06e996a7a, type: Release
build date: 14/01/2019, 12:00
platform: Windows

These are the results of my tests, in case there's any other thing that I'm missing from the original report:

Testing steps

  1. I created a closed "perfect" shape (circle tool) and an open shape (brush tool) in the first layer.
  2. Fill settings were: Leak size: 0px; Thickness: 1px; Simplify: 0px
  3. Created 3 additional layers to contain the filled shapes.
  4. On each layer, using different material colors, each shape was filled twice: First putting the layers on top of the lineart layer, then again filling the layers that were put below the lineart:
    • Tested filling the closed shape
    • Tested filling the open shape
    • Tested filling the open shape after closing it visually by crossing two segments (didn't use the <toggle cyclic> option).

In all cases above, using the fill layers either on top of or below of the lineart fill behaves correctly, no crash happened. So for me the problem at hand seems to be fixed, but hopefully the OP can also test the latest nightly on their system to validate if the fix is working for macOS.

Either way thank you very much for the hard work!

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Thu, Mar 7, 2:53 PM
Sebastian Parborg (zeddb) closed this task as Resolved.Fri, Mar 8, 11:24 AM

I can't reproduce this either. If it is still not fixed on mac, we can reopen this.