Page MenuHome

Letting go of "D" turns on Continuous Drawing
Closed, ResolvedPublic

Description

Blender Version
Broken: 2.79b

Short description of error
When drawing with "D" held down (and Continuous Drawing disabled) and the user lets go of "D" before completing the stroke, Continuous Drawing will become enabled.

Strangely enough, this problem doesn't exist in Blender 2.8.

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) closed this task as Resolved.
Antonio Vazquez (antoniov) claimed this task.

This is not a bug. In 2.7x if you draw pressing D and release it before finish stroke, the continuous drawing is enabled.

Hi, thanks for the response, Antonio. Is it possible to make 2.79 act like 2.8 and not make it enable Continuous Drawing?

I keep accidentally enabling it due to this behavior, leading to the problem in T60548.

No, the changes between 2.7x and 2.80 are so big that it's is impossible to port this feature (I could disable it, but it will break this feature used for lots of users). You could change it if you edit the code and recompile a custom version for you only.

If you keep the D pressed while you draw and don't release before finish the stroke, the continuous mode is not enabled.

Got it. Will try to take care not to accidentally enable it.

Keep up the good work; Looking forward to being able to use 2.8 Grease Pencil for production!