Page MenuHome

Undo/redo affects brush options in vertex paint mode.
Closed, ResolvedPublic

Description

System Information
Operating system: win8.1
Graphics card:hd4000

Blender Version
Broken:
(example: 2.80, fc6aac391679, 2019-01-18)

Short description of error
In vertex paint mode, all of brush options are being affected by undo/redo.
Exact steps for others to reproduce the error

  1. Create any object with geometry (suzzanne is fine)
  2. Change brush size for example (You can change anything in brush menu, curve/brush/strenght etc.)
  3. Hit undo

Undo/redo should not affect this options and should only affect painted strokes just like in texture paint mode.

Details

Type
To Do

Event Timeline

Here, undo actually affects both. Only Texture Paint color specifically is not registered with undo.

@Campbell Barton (campbellbarton): What is the intended behaviour for undo here?

Strictly speaking intended behavior is that changes to brushes undo,
internal workings meant this only happened sometimes.

  • Vertex paint uses memfile undo (storing everything).
  • Texture paint uses it's own undo stack.

Setting this report as a TODO since there are many issues with undo that need attention and this inconsistency isn't a new issue in 2.8.

Campbell Barton (campbellbarton) lowered the priority of this task from Needs Triage by Developer to Confirmed, Low.Jan 25 2019, 12:34 AM
Campbell Barton (campbellbarton) changed Type from Bug to To Do.
Demeter Dzadik (Mets) closed this task as Resolved.Sep 14 2019, 3:50 AM
Demeter Dzadik (Mets) claimed this task.

Closing because as far as I can tell, this is a duplicate of T61948. Re-open and correct me if I'm wrong.