Page MenuHome

Adding Scene to Video Sequence Editor causes horrible lag
Closed, ArchivedPublic

Description

Blender Version
Broken: 2.8 January 30, 01:09:07-a1ae04d15a9f

Short description of error
Just as the title says. The scene can be empty with a single camera and playback will be horrible.

To reproduce:

  1. Open Blender.
  2. Delete everything in scene.
  3. Create new Main Window and set it to VSE.
  4. In the first window, Add a new scene.
  5. Add a camera to the scene.
  6. Back in the VSE, add the newly created scene.
  7. Check playback.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

This area still needs more optimization, we do not currently consider that a bug though, it's part of general development.

Is the source of slow rendering known?
I should at least look at this, as I don't use blender for modelling therefore I am less likely to notice and trace such issues

There are a few reasons why this can be slow: dependency graph build and evaluation, creating OpenGL contexts, color management, etc. The issue is not likely to be specific to the VSE.