Page MenuHome

wrong normal interpolations with AO node
Closed, ArchivedPublic

Description

System Information
Operating system: win7 SP1
Graphics card:geforce GE610 DX11

Blender Version
Broken: 2.79.6 ( but i tried with the latest build and the problem still appears
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
the best thing is an image and a blend ;)
EDIT: i have to mention the mesh has no overlapping polys and all normals are properly oriented

The problem occurs when in render mode in 3D view. normal artifacts are also visible on the external round part of the tower. The strange thing is that those artifacts change when moving the object in object mode, or the whole mesh in edit mode.
The sharp marked edges change things in artifacts appearance/position.....
As the 2.79b don't have the AO node ( but an AO shader ), those artifacts don't appear.

As a conclusion, this bug wouldn't be a big problem if it were only visual in 3D view, but those artifacts also appear in baked AO and final renders.

Hope i can help making blender better :))
and also to hear from you soon 📦

best regards

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
just open the blend, move nothing and switch to render mode in 3D view.

Details

Type
Bug

Event Timeline

CJ L (pitibonom) updated the task description. (Show Details)
Brecht Van Lommel (brecht) closed this task as Archived.EditedJan 31 2019, 5:05 PM
Brecht Van Lommel (brecht) claimed this task.

This is a ray tracing precision issue due to objects being relatively far away from the origin.

We are aware of this problem, some improvements are being worked on (like D1212) but not finished yet.

CJ L (pitibonom) added a comment.EditedJan 31 2019, 8:04 PM

hey Brecht !
well okay....
i'm a former programmer and it appeared to me it was what you're talking about.
Yes. 32 bits float do not allow accuracy in wide scales.
all this makes sense but as am not a blender dev ( and to be honest on won't consider putting my nose on this huge ( inaccessible for me ) project.... )
could you plz tell me wether you got an idea of this """"""bug""""" resolution, tho it's just not a bug but a precision problem ?

mebe it will be solved in 2.8 ?

of mebe in a 2.79.xxx release ? ( i wish it were )
time to switch from float to doubles guyz :P from what i saw, on intel machines doubles and floats handle quantities in almost the same speed ;))

CTRL+R float double RETURN x))

ahahah !!!! of course am kidding you !
okay, i'll find a way on my prob..... gimp will help ^^
i'm very comprehensive and 'loving' on blender. i wish i had time and knowledge to help....
am just a 'fan' user. in admiration of the work done on this awesome tool.

not sure u can keep me up on the updates concerning my problem ( or some others, they are legions ) but i keep an eye on what is done.
Unfortunately, the 2.8 beta still don't meet my needs. therefore i gotta do with 2.79.xxx buggies :))

keep up the work !
and
above all !!!!!
THANKS !! MANY MANY THANKS !! for all the work done !!!

best regards.

We don't know yet when it will be solved, it's not an immediate priority for us at the moment. D1212 has some ideas to improve the situation, but we need to investigate more.

Moving objects closer to the original is often possible and can help.