Page MenuHome

Viewport can only show the first three vertex color layers
Closed, DuplicatePublic

Description

System Information
Operating system: macOS Mojave 10.14.2
Graphics card: Radeon Pro 560X 4096 MB
Intel UHD Graphics 630 1536 MB

Blender Version
Broken:

2.80, 08ab09cf04d9, blender2.8, 2019-02-05, as found on the splash screen)
Download file is blender-2.80.0-git20190205.08ab09cf04d9-x86_64

Worked: only on 2.79

Short description of error

On 2.80, whenever I add a 4th Vertex Color layer, it appears as dark gray on Vertex Paint mode. This goes for all remaining colors.

Exact steps for others to reproduce the error

When I transfer the object to 2.7 is shows all the colours. It also renders as if the layer is working, but I can’t paint on it unless I’m in LookDev mode, which is heavy on my computer.

The curious thing is: when I delete the first 3 layers, the next 3 become visible again.

Also, why the 8 layer limit? I’m colouring makeup on my avatar and I’d love some extra layers…

Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Confirmed, Medium priority.Feb 6 2019, 11:12 AM

I can confirm the drawing issue.

I don't know exactly why there is an 8 layer limit, probably historical reasons, should be fixed at some point in the future. However, that is outside of the scope of the bug tracker.

Jacques Lucke (JacquesLucke) renamed this task from 2.8 - 4th Vertex Color layer is always greyed out (on the viewport) + Only 8 layers of Vertex Color? to Viewport can only show the first three vertex color layers.Feb 6 2019, 11:13 AM