Page MenuHome

macOS: CTRL+R and MagicMouse
Open, Confirmed, MediumPublic

Description

MacOS 10.14.3
2017
27"
5K

I ask you again before they ignore me what I told them few times.
Pusht eh Control+R then very hard to move finger go up and very easy to move finger go down.
Please to fix make very easy to move finger go up.
Please use Macintosh. Do not use Windows.
Use MagicMouse.
Thanks.
I am still stubborn to ask you bug until fix it right.

Details

Type
Bug

Event Timeline

William Reynish (billreynish) closed this task as Invalid.

I'm not sure there's anything we can do about this. The Magic Mouse touch surface uses momentum scrolling, and I don't know that we can control this. It's just how that mouse was designed to work. It's an issue with the design of the mouse and not Blender.

You could use a different mouse, or not use the scroll wheel for this, or change the way you release your finger while scrolling to stop the momentum.

Yes that Blender 2.80 does. 2.79b is good work and Blender 2.80 bug. This Macintosh is fine. Need to fix correct math on move scroll up and scroll down.
Very hardest move scroll up and easy mouse scroll down while Control + R

Come on please stay open. Do not make close. I am still stubborn to tell you bug on Blender 2.80!

I found a solution for how to disable inertial scrolling on the Mac: https://www.idownloadblog.com/2017/01/17/how-to-disable-inertial-scrolling-on-your-mac/

This should solve your problem with the Magic Mouse. If not, report back.

William Reynish (billreynish) triaged this task as Needs Information from User priority.Feb 6 2019, 10:51 PM

No that is not answer on System Preferences.
Blender 2.79b is fine and Blender 2.80 is bug! very hard to move scroll up and I have to finger move too fast and fast make edge add.
Very so slowly down finger move down become edge to 1.
Please do fix math on Blender 2.80 code.

I don't understand what you are saying unfortunately. Does disabling inertial scrolling change the scrolling behaviour for you with the Loop Cut modal operator?

Push the Control + R then finger move up scroll fast and fast fast fast hard to make multi edge then finger move very vvveeeeeeerrryyyyyy slowly scroll down make multi edge become 1 edge.

View 3D Youtube You will see how hard finger scroll up and finger scroll very very slowly down you see edge.
https://youtu.be/1lG0uLMpiiE
I have fight hard to up and down scroll until finally 3 edges.

I still don't understand what you are trying to say exactly. Do you mean it is too sensitive?

And please, try the suggestion earlier and report back when you have tried disabling inertial scrolling.

Finger scroll down veery much too sensitive multiply edge become 1 too fast.
Finger scroll up is never too sensitive 1 edge become multiply edge very hard.
MacOS is not kind System Preferences Accessibility I ignore it. I knew it Blender 2.80 have bug code itself.

Please try the suggestion earlier and report back when you have tried disabling inertial scrolling.

I am sorry I ignore it on System Preferences.
Can you show me where is Edit > Preferences on keymap tab Ctrl+R = Loopcut and I will look up and get code to fix.

As in the link I posted. System Preferences > Accessibility > Mouse & Trackpad > Trackpad Options. Set to Without Inertia.

System Preferences on accessibility is not belong on Blender 2.80. I has been told Discord on https://discord.gg/buUa7S and I will wait for they do use Macintosh can tell you. Blender 2.80 need to fix code support on MagicMouse scroll up and down.


Did you already take test on Blender 2.80 on create plane and edit mode then Control+R (Loopcut) use your real MagicMouse?
Not use Windows mouse.

Yes, scrolling works normally here on Mac.

Now, I ask for the last time, please try the suggestion earlier and report back when you have tried disabling inertial scrolling.

[√] Scrolling (with inertia)
[√] Scrolling (without inertia)
[ ] Scrolling (with inertia)
[ ] Scrolling (without inertia)
I did test still Blender 2.80 bug!

I am use MacOS 10.14.3 Mojave

Yes, there is definitely a bug. (At least there is a big difference compared to 2.79b.)
Try the trackpad on MacBook.

When you scroll up, there's very low sensitivity, you need to scroll very quickly.
When you scroll down, then very high sensitivity, instantly resets to value 1.

Look at how sensitivity works when you change the number of segments in the Bevel tool, this is very good.

MacOS 10.14.3
February 07, 00:06:21 - 9df460203517
MacBook Pro 2016

William Reynish (billreynish) reopened this task as Open.EditedFeb 7 2019, 11:02 AM
William Reynish (billreynish) raised the priority of this task from Needs Information from User to Confirmed, Medium.

Ok, thanks for testing with inertial scrolling on and off. And thanks @Yevgeny Makarov (jenkm) for the clear explanation of what the problem is.

@Brecht Van Lommel (brecht) Not exactly sure who to assign this to, given that Mac trackpad input is handled differently from other scrolling in Blender.

@Yevgeny Thanks.
Now I am wait for Blender 2.80 to fix bug.

I am still wait for your bug fix.

@Kent Davis (mac4kent) There are about a thousand bugs, it may take a long time to fix it. :(

@Yevgeny
Oh really about a thousand bug, now I understand. Thank you for explain me no problem.

@Chris Evans (mgchris) I know you have magic mouse if you have free time to inspect above message.

@Kent Davis (mac4kent) it will be a bit before I can look into this, but I should have some time next week or so.

March 17, 2019
I am wait for you to process to answer and fix. @Chris Evans (mgchris) but take your time to inspect.

Campbell Barton (campbellbarton) renamed this task from CTRL+R and MagicMouse to macOS: CTRL+R and MagicMouse.

I am still wait for you process for Mac on Blender 2.80 daily build.

April 21, 2019
Hello. I am still wait for you to processing for Mac Blender 2.80 BETA