Page MenuHome

Hair system behaves wiered when module append from 2.79b file to 2.8
Closed, ArchivedPublic

Description

System Information
Operating system: Intel i3 gen-6
Graphics card: no graphic card (I use CPU compute)

Blender Version
Blender 2.80 beta (windows) 2.80 Beta Windows 64 bit
February 09, 02:27:46 - 191b8951f7af
Beta
119.35MB

I was working on my blender character from a month (in v2. 79b) and today I tried to continue on it with v2.80 beta but when I opened my file in 2.8 my hair system of character related weirdly and all hair particles get scattered weirdly over the character and nearby the character I tried several times but same thing happened then I tried to append it from that file to a new file but again it created more weird effect and I tried several times but nothing happens.
This bug is only in blender files of 2.79b opened in 2.80 beta when I tried to append that object from that file to a new file of blender 2.79b it doesn't created that weird effect and remain perfect.

Exact steps for others to reproduce the error
To reproduce the error create a blender file in blender v2.79b with a bit complex hair system and try to open in it in blender 2.80beta or append that object from that file to a new file of blender 2.80beta. The hair particles will not react weirdly.

Thank you

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

There were some hair fixes recently so please retry on the latest blender beta.

If the problem still happens, please create a minimal .blend file that demonstrates the issue.
Preferably by just using the default cube and adding a hair system to it.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Following bug tracker policy, closing report after 7 days due to insufficient information to investigate further. We can reopen the report if more information is provided.