Page MenuHome

Channel of particle settings is not shown in Graph Editor
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu 18.04.1 LTS
Graphics card: GeForce MX130/PCIe/SSE2

Blender Version
Broken: 2.80, 191b8951f7af, blender2.8, 2019-02-08
Worked: Last known in 2.79

Short description of error
If you try to animate more than 1 keyframes in particle settings, you didn't get those keyframes in the Dope Sheet Channel Context Menu

Exact steps for others to reproduce the error

  1. Add new particle on any mesh
  2. Add keyframe on one of the animate-able parameters in particle settings (let say Scale and Scale Randomness)
  3. Open Graph Editor
  4. Try selecting one of the F-Curves in the Dope Sheet Channel Context Menu, there's no keyframe of Particle Setting to select

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Seems to work for me with the latest commit, can you try a newer build?
Or am I misunderstanding the problem?

oh, I'm sorry I forgot to attach the image

As you can see, on the material channel, it contains 4 different channel for different keyframes (2nd image) while the particle system's channel only have one grouped channel even though it has 2 keyframes (1st image)

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Confirmed, Medium.

Seems to work for me in the newest version.
Is this still an issue for you?

Sebastian Parborg (zeddb) closed this task as Resolved.Mar 14 2019, 1:09 PM

I can't reproduce this either now. Let us know if this is still a problem and we can reopen this.