Page MenuHome

Eevee: Random attribute in 'Object info' node malfunctions when object with particle system is link duplicated
Closed, DuplicatePublic

Description

System Information
Windows 10 Pro 64 bit - i7 6880k MSI GTX1080 X Gaming

Blender Version
Broken:
version: 2.80 (sub 44), branch: blender2.7, commit date: 2019-02-10 00:16, hash: 0b6dbbc306b0, type: Release
build date: 09/02/2019, 17:04 - BUT as already logged particle system is broken in this build anyway.
Also Broken in
version: 2.80 (sub 44), branch: master, commit date: 2019-02-08 14:02, hash: 29922b6ff5f4, type: Release
build date: 08/02/2019, 06:14 WHERE particle system works.

Short description of error - Using eeVee

If you create an object with a material which uses the Random attribute in the 'Object info' node to control a colour ramp which is used to colour the shader in the object's material. Then add some particle hair. Then link duplicate (ALT-D) the object the Random attribute will not affect the colour properly. Infact if you render a number of frames the colour of the objects can flash in some frames to the other colour. Also seems to be the same for SHIFT-D though I have had varied results. If you hide the particle system for an object it's colour becomes the correct one.

As mentioned above... particles is broken in the Feb 9 build and particles will only display on the selected object and will not render so use Feb 8h build. This bug has been reported by someone else.
Blend file attached{F6569635}

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.Mon, Feb 11, 4:39 PM
Sebastian Parborg (zeddb) renamed this task from Random attribute in 'Object info' node malfunctions when object with particle system is link duplicated to Eevee: Random attribute in 'Object info' node malfunctions when object with particle system is link duplicated .