Page MenuHome

Weird clip start from 3d ortographic views
Closed, ResolvedPublic

Description

System Information
Operating system:Ubuntu 18.10
Graphics card: GeForce GTX 980 Ti/PCIe/SSE2

Blender Version
2.80 (sub 44), branch: master, commit date: 2019-02-16 10:25, hash: 03ede79c4fbe, type: Release

Short description of error
Clip start from 3d ortographic views (front, side, top...) is cutting with default value of 0.1
I need to change to 0.5 to back to normal but 0.5 is too high for perspective viewport.
I believe that this commit is causing this behaviour: https://developer.blender.org/rB2f737c4f475a5625f9140b84ffd55435ca2fd805

Exact steps for others to reproduce the error
Just add a monkey and press numpad 1 to enter front ortographic view, it happens in all ortographic views.

Details

Type
Bug

Event Timeline

I can't see any problem.
Does this happen if you start Blender with --factory-startup?
If so, please attach a .blend showing the problem.

From a quick glance, that commit only changes variable names.

I see this problem with factory startup also...
Here is a simple .blend and a screenshot.


I can confirm it on my side. Linux Mint 19.1 / GTX 1080ti. Very latest build of 2.80.

Yes can confirm this weird clipping in my win 7 gtx 550ti, own build hash: 0d86259fc8a3 we didn't have in the earlier build.

Sebastian Parborg (zeddb) closed this task as Resolved.
Sebastian Parborg (zeddb) claimed this task.

I can't reproduce this issue with the latest commit and it seems like Campbell fixed it with this rB4bbd1b9610f6d85079ea5bc31fc1949f8409a1a4