Page MenuHome

Lagging Issue After Error Report(s)
Closed, ArchivedPublic

Description

System Information
Operating system: Microsoft Windows 10 Pro (32-bit)
Graphics card: Mobile Intel® 4 Series Express Chipset Family (Microsoft Corporation - WDDM 1.1)
Blender Version
Broken:
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: Never

Short description of error

Hello!
I just recently got Blender last night (wanting to learn how to use it/a beginner) and found out that I needed to place in a opengl32.dll into the Program file for Blender itself to start working. Once I placed it in I got it to work and finally I could open it up.

But I soon found out that once I did open it up, it became very laggy to the point of where I literally had to wait 5 to 30 seconds to do the next action. I am not so sure if I had done anything incorrectly with this?

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Downloaded the blender .zip and .msi from the official Blender website

Unzipped it
The file that I had downloaded did not come with the opengl32.dll in it:

Made sure to have it on my desktop
Opened it up and gave me this error:

Went to Local C Disk -> Program Files -> Blender Foundation -> Blender -> Dropped the opengl32.dll into the folder that had all of this in it:

I had to find it on the web and I did (I found it on this website):

Exited out of the folder and went to my desktop, clicked on it and it loaded up but with a lot of lag:


Details

Type
Bug

Related Objects

Event Timeline

and found out that I needed to place in a opengl32.dll into the Program file for Blender itself to start working.

Where did you get this idea from? Blender is a perfectly standalone software, you should be able to just download it and run it. If you can't, then that's a problem enough on its own to be worth reporting here, so from there the fact that this particular workaround isn't working seems irrelevant. Why do you need this workaround to begin with, what is it meant to fix, and where did you find it?

In the error picture (down below) shows the red "x"

,it continued to pop up repeatedly over and over again, never opening up the program itself.

I got the idea of having that piece put in since I googled the error (about 12 different ways-) before finding an answer to the solution.

I do have a graphics card that works with any of the 3D programs I have (such as MikuMikudance, PMXe, and PMDe). I just have no idea why this error continued to appear. I do apologize if I have done something wrong.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Feb 18 2019, 12:20 PM

The opengl32.dll forces blender to use software rendering for OpenGL. This is only useful for debugging purposes as the performance will be really bad.

As the error states, your current GPU drivers does not support OpenGL 2.1. This is probably because you have not installed any GPU drivers as OpenGL 2.1 is from 2006, so it would be weird if your GPU didn't support it.

Try to download the drivers for your intel card here: https://downloadcenter.intel.com/product/80939/Graphics-Drivers and remove the opengl32.dll you put in the blender folder.

Report back here with your progress.

Brecht Van Lommel (brecht) closed this task as Archived.EditedMar 1 2019, 4:01 AM
Brecht Van Lommel (brecht) claimed this task.

This graphics card is no longer supported by Blender. Software emulation is probably the only option, but it is indeed very slow.

Your best bet is to use an older Blender release:
https://download.blender.org/release/