Page MenuHome

texture paint problem
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: macOS Mojave 10.14
Graphics card: Intel Iris Graphics 6100 1536Mb

Blender Version
Broken:
2.79.7, date 2019-02-06 14:18, hash fccf506ed7fd
Worked: (optional)

In the texture paint mode preview window shows nothing. In case I start painting an press Cmd+z (ctrl+z for windows) the system freezes.

no special actions needed. the problem reproduces just always.

Details

Type
Bug

Event Timeline

Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.Feb 18 2019, 2:55 AM

This report doesn't provide steps to redo the bug, please include exact steps from factory settings or include a blend that exposes the problem.

  1. create new plane
  2. add new material, assign it to the plane
  3. create new image (default setting for example - it doesn't matter)
  4. go to shader editing, plane material
  5. add new texture - image texture node
  6. choose our new image for the texture node
  7. select our plane and switch to texture paint mode
  8. In the lleft menu column ("t" button) choose texture, new texture
  9. Go to the texture tab in the Properties panel
  10. In the dropdown menu choose Brush - texture (our new texture name - .001 by default)

Now I can see that the preview doesn't show any info at all. It doesn't matter whether I choose clouds or noise of Image.

furthermore

  1. in the 3d window make a stroke with your new brush
  2. press ctrl+z or cmd+z to start blender freeze

Same bug happens now on windows 7 2.79 build from 2019-02-01

Pavel Golubev (pavgolubev) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Feb 19 2019, 11:51 PM

new versions uploaded, no such problem for windows, but it remains for mac

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Is this still an issue?
I am not sure I understand what you mean by "paint mode preview window" or "preview doesn't show any info at all"

Could you possibly share a screenshot showing this issue?

Philipp Oeser (lichtwerk) closed this task as Archived.Mar 27 2019, 1:05 PM

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.


I have uploaded new screenshot. on the left you can see stable 2.79 (everything is ok), on the right - last experimental build for today. I have marked the problem with red circle. Moreover, I repeat, it's just a symptom. The main problem is that you can't undo any texture paint action - the software freezes

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mar 27 2019, 2:26 PM

Still cannot reproduce here (seeing the preview, can paint and undo), but maybe someone on a MAC can reproduce?
@William Reynish (billreynish) : are you on a MAC?

Only mac related problem. Have been testing this on windows - everything works fine