Page MenuHome

Cycles ignores 'Local View' mode during Prreview
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu 18.04
Graphics card: GTX 970

Blender Version
Broken: 2.80.45, Date: 2019-02-21 10:59, Hash: 1bfbfa281046

Short description of error
When I try to preview an Object in Local View with Cycles, all my objects are rendered together. It seems that Cycles ignores Local View.

Exact steps for others to reproduce the error
Open Blender.
Select the Cube and duplicate it.
With your selected Cube, press '/' to enter in Local View.
Set Cycles as Render Engine.
Set 'Rendered' as 3D View display method.

Blender should normally only preview your selected Cube. However it preview both.

Here is the .blend file:

And a screenshot:

Details

Differential Revisions
D5753: Cycles: Initial Support For Local View
Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Confirmed, Low priority.

Was going to report this but saw that it's already here :)

I hope this gets fixed soon. It's a serious inconvenience especially when working on large scenes.

I was about to post the same thing. Pretty annoying not being able to speed up single elements preview for large scenes as already mentioned.

I was about to post the same thing. Pretty annoying not being able to speed up single elements preview for large scenes as already mentioned.

+1

It's been reported so many times yet it still sits here at low priority :(

+1

This slows down production, it would be very good if it's getting fixed soon.

2.8 is officially out! But this bug stills in LOW PRIORITY. No comment!
It slows down production, especially working on large scenes. Hope it will be fixed soon.

It would be great to know why this bug is delayed as no one from the team said anything regarding this issue. Neither has been fixed yet and it's extremely important for some people.

Brecht Van Lommel (brecht) raised the priority of this task from Confirmed, Low to Confirmed, High.Aug 2 2019, 4:33 PM

It will be fixed for the next release.

Thanks for switching this to high, Brecht.

From LOW to HIGH Priority. It's a good news. Thanks
We'll wait for the next release

@Brecht Van Lommel (brecht) : I have added this to 2.81 milestone (since it was set to "High"), mind checking again?

Was looking the backlog and saw this ticket. Will engage :-)

Seems like that every draw engine does the local view check. I will be looking to put this into the depsgraph iterator. This way any render engine can use local view out of the box.

Jeroen Bakker (jbakker) closed this task as Resolved.Fri, Sep 13, 11:38 AM