Page MenuHome

Bevel Modifier with Limit: Angle, Outer Miter: Arc, Clamp override with 0-displacement extrudes exhibits odd behavior.
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 Pro
Graphics card: GTX 1080 T

Blender Version
Broken: 2.80, 6bab905c9d40, 2019-02-24

Short description of error
When you extrude a face and right click to cancel the displacement, the mesh freaks out if a Bevel Modifier with the following conditions is applied:
Limit: Angle
Outer Miter: Arc
Clamp Override

If clamp override is disabled, relatively normal bevel behavior is displayed. If the Outer Miter is set to Arc, or the limit is set to none, the unbeveled mesh is displayed. Only with all three of these settings does the mesh freak out.

Gif demoing the problem:

Exact steps for others to reproduce the error

  1. Create an L shape similar to the one in the gif above.
  2. Apply a bevel modifier with the depicted settings.
  3. Extrude the same face as in the gif. Not all geometries produce this result when extruded.

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Confirmed, Medium priority.

The problem disappears when the face at the top is moved.

Thanks, I will look at this.

Howard Trickey (howardt) closed this task as Invalid.Apr 2 2019, 1:20 PM

The problem is not with bevel, really. It is that right-click to cancel extrude doesn't cancel it -- it just sets extrude amount to 0. So we end up with two faces on top connected with zero-length edges. This is not a situation for which bevel is intended to work well.

I will make a separate bug about cancel not completely canceling an extrude, but closing this one as invalid because bevel is not meant to work under these conditions.

The cancel extrude thing has been reported before and not considered a bug I think. The problem is that it's actually useful to be able to cancel just the transform.