Page MenuHome

Cannot join areas.
Closed, ArchivedPublic

Description

System Information
Operating system:
Windows 10

Graphics card:
Quadro GP100

Blender Version
Broken:
2019-02-24 22:02 893fa598319e

Short description of error
Click the corner of areas and try drag to merge, only split more areas out.
Tried right click and join, but not work.

Exact steps for others to reproduce the error
click the corner of the areas and drag to split, try split more with vertical and horizontal, and now do join area operation with either drag corner, or right click area corner join areas

Details

Type
Bug

Event Timeline

Tried join area, just become more and more.

I agree that the join and split situation is even more cumbersome in 2.8 than it already was in 2.79.

It's not only counter intuitive as always but now the pixel margin feels even smaller

@Pengfei Hao (intijk), the image shows that you accidentally split lots of areas. But could you try to explain a bit more about the experience you had? Were you able to do so in 2.8x but now cannot, or are you new to splitting/joining in general? It is certainly a hidden feature, but I find it works well once you know how it is supposed to work. It can definitely be frustrating when trying it the first time.

We definitely need to make it easier to do splitting and joining without using the corners. And leave this corner stuff as an advanced feature. But first I need to know more about your trouble in particular.

i have given up on trying join areas by dragging, right clicking the border between to areas and selecting join in the way to go for me.

@Pengfei Hao (intijk), the image shows that you accidentally split lots of areas. But could you try to explain a bit more about the experience you had? Were you able to do so in 2.8x but now cannot, or are you new to splitting/joining in general? It is certainly a hidden feature, but I find it works well once you know how it is supposed to work. It can definitely be frustrating when trying it the first time.
We definitely need to make it easier to do splitting and joining without using the corners. And leave this corner stuff as an advanced feature. But first I need to know more about your trouble in particular.

Glad to add more details here.

I was using the default manual to learn some layout knowledge. https://docs.blender.org/manual/en/dev/interface/window_system/areas.html#splitting-and-joining

So I tried to click hold the area corner to drag split, was working fine. I do the same operation try to join them, not always success, some times it just split more areas out, sometimes it shows a bit white arrow, and I could join two areas. I want to join everything together(can we just join all of them with one button?), I accidently split more areas out because I cannot see those big white arrow and I don't have a way to cancel the split operation after it split out.

Then you see, it comes more and more areas.

Then I tried to right click the areas corner(as the manual told me), there is a join areas option, tried right click on each corner, but non of them join.

That is all the information I could give.

you have to right click on the thin line between 2 area's, the one you normally use to resize them.

Thanks @Pengfei Hao (intijk). Your feedback is especially important, being new to trying this.

This might sound odd, but I am trying to get information about your experience and expectations without just telling you how to do it right. So I am going to ask more questions about it *because* you had a frustrating experience trying it because that makes you ideal to give feedback.

When I look at that same manual page, I also do not find it clear. It talks of movements "inward" and "outward" and I think that could be a problem when we are talking about a movement that is between two rectangular areas. Was that part confusing to you too? Or did the manual explain well the *direction* that you needed to move?

More importantly, that page seem to imply that you should *start* at the edge, right in between the two areas. And that is actually bad advice if that is how you interpreted it. Is that how you read it? That your mouse should be close the middle between the two areas, right in the corner?

Thanks @Pengfei Hao (intijk). Your feedback is especially important, being new to trying this.
This might sound odd, but I am trying to get information about your experience and expectations without just telling you how to do it right. So I am going to ask more questions about it *because* you had a frustrating experience trying it because that makes you ideal to give feedback.
When I look at that same manual page, I also do not find it clear. It talks of movements "inward" and "outward" and I think that could be a problem when we are talking about a movement that is between two rectangular areas. Was that part confusing to you too? Or did the manual explain well the *direction* that you needed to move?

The documentation is somehow confusing, but I still get it, the thing is software don't always react the same manner, sometimes it allow me to join, sometimes not. I tried both directions.

You can think this is a documentation issue, but software has some bug definitely.

More importantly, that page seem to imply that you should *start* at the edge, right in between the two areas. And that is actually bad advice if that is how you interpreted it. Is that how you read it? That your mouse should be close the middle between the two areas, right in the corner?

start at the edge is to adjust the size of the area, I don't have problem with that. split/join is what I intend to do, as the doucmentation told:

"Placing mouse cursor in area corner will change cursor to a cross (+) to indicate that pressing down LMB will activate splitting or joining command."

@Pengfei Hao (intijk),

You can think this is a documentation issue, but software has some bug definitely.

But thanks for indulging me in this.

start at the edge is to adjust the size of the area

The problem is you can't really start at the very corner, right in between the two areas. In fact the closer you put your mouse to the middle the worse it will be and it will be more likely that you get the wrong result. And that part is definitely not clear in the manual.

I will see if I can make some images to better explain that and will post them here to see if they make sense to you. But it might not be right away. Thanks for your help.

Oh, I some how see what you mean.

I found the stable join is to right click on the edge of two areas and click join, instead of right click on the corner.

Drag corner to join areas works like a mystery.

@Pengfei Hao (intijk)

I hoping that you can look at the following image. Hopefully it will be clear that there are three areas in this image. There is one area, mostly in view, with another area to the left and above. If not clear, please let me know.

I am hoping you will try again, but this time make the middle of the yellow highlighted area your target. So you are are not aiming in between the two areas, but into the meat of the corner of this area.

From the yellow area you should be able to drag right to split the area shown. Or drag down to split the same area in the other direction.

Dragging *up* from the middle of that yellow highlighted area should join to the area above.

Dragging left will do nothing.

I am mostly wanting to know if my instructions here are clear.

Campbell Barton (campbellbarton) closed this task as Invalid.

Closing since this isn't a bug, more a limit in how joining works.

While improvements here are welcome, the tracker is for software errors/bugs.

If a developer plans to work on this and wants to discuss changes, a design task can be opened.

Otherwise it's not helpful to have so many issues open.

@Campbell Barton (campbellbarton) Can I make a "design task"? I've never seen an option about such a thing.

Sorry if this is something that should be already known.

@Harley Acheson (harley) I think it's only developers w/ commit access that can do this.

If you plan to work on this now and need a place to discuss changes - I'll change this to a design task.

Hi Harley,

I know what you mean, the fact it, I tried every corner in every direction, but when there are many areas exist, non of those drag will trigger the merge action.

This is a bug report , not a design improvement request.

@Campbell Barton (campbellbarton)

I think it's only developers w/ commit access that can do this.

No worries.

If you plan to work on this now and need a place to discuss changes - I'll change this to a design task.

I don't think that is necessary in this case. I think it has become obvious that this is an education issue that I can help by improving that page in the manual. You can close this and I will see how to get in touch with the editors or just get myself involved there.

Thanks again for your help.

Pengfei Hao (intijk) reopened this task as Open.Feb 26 2019, 3:29 AM

Hi @Campbell Barton (campbellbarton) :

What I am reporting is that drag join areas not working when there are many areas.

Is this too small to fix issue?

@Pengfei Hao (intijk) this is a limit in joining areas, its been this way for a long time and something you can work-around.

Appreciate there are many things we could improve but can't have this tracker becoming a place to discuss paper cuts - or it would become unmanageable.

@Pengfei Hao (intijk) this is a limit in joining areas, its been this way for a long time and something you can work-around.
Appreciate there are many things we could improve but can't have this tracker becoming a place to discuss paper cuts - or it would become unmanageable.

understand.

my first reaction to see this isse was to click help -> report which guide me here.

thank you for let me know there is a paper cut thread.