Page MenuHome

Build modifier for Text object builds characters in the reversed order.
Closed, ResolvedPublicKNOWN ISSUE

Description

System Information
Operating system: win10
Graphics card: GeForce GTX 1060 6GB

Blender Version
blender-2.80.0-git.dd9cedddae69-windows64

Short description of error
As in the title. Build modifier for Text object goes from the last character to the first.

Converting Text to Curve object or Mesh object makes it work as expected.

Toogling 'reversed' checkbox doesn't help as it reverses the time not the building direction.

Exact steps for others to reproduce the error

Open the file and play animation

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from 90 to 50.

@Campbell Barton (campbellbarton) found the issue here.

In blender/editors/object/object_add.c:1994 we convert the text object to a curve first, this causes the order in which the geometry indices are build to be reversed.
However, it seems like the current code can convert OB_FONT without any problems so if I remove that conversion, it seems to work fine.

I'm guessing that is is like this for a reason or is this simply something that is not needed anymore and can be removed?

I should also note that there seems to be a mem leak here too when converting to mesh:
Error: Not freed memory blocks: 15, total unfreed memory 0.032776 MB

Mem Leak might also be related to T60211

Richard Antalik (ISS) changed the subtype of this task from "Report" to "Known Issue".
Sebastian Parborg (zeddb) closed this task as Resolved.Mar 2 2020, 3:43 PM

This one seems to be fixed in master now.

The result is the same for the text and the mesh object.

Build modifier for Text still works in reversed order.

System Information
Operating system: Linux-4.15.0-20-lowlatency-x86_64-with-debian-buster-sid 64 Bits
Graphics card: Mesa DRI Intel(R) Haswell Mobile Intel Open Source Technology Center 4.5 (Core Profile) Mesa 18.0.0-rc5

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-03-12 05:06, hash: rB375c7dc4caf4
Broken: version: 2.83 (sub 17), branch: master, commit date: 2020-05-22 19:52, hash: rBe8dd8c2829f3

The issue reported here was that the build modifier would switch directions when converting a text object into a mesh.
This is not the case anymore so that issue is fixed.