Page MenuHome

Blender V2.80 does not render Geometry/Backfacing - Shader Editor
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: AMD Radeon R9 200 Series (ASUS R9 290X DirectCU II OC)

Blender Version
Broken:
V2.80, 490a385c8124, 2018-03-02
Worked:
Blender V2.79b

When creating a material with an image texture and with a different colour on the back side of the object, using a png file with transparency, it does not render with Device setting 'GPU Compute'. The viewports show the object with the correct texture and render but in the render window the object, with the front and back different colours, renders black. When switching to CPU then the render is correct. This exact same setup works in V2.79b

I attached a test file which demonstrates this. I also attached the exact png image I used for this test. The renderings I attached was made with the CPU, the red is the front and the blue is the back face of the object.

The black object is rendered from the back face with the GPU Compute settings, which demonstrates the problem.





Event Timeline

Andrew Sprok (sprad001) renamed this task from Blender V2.80 does not render Geometry/Backfacing to Blender V2.80 does not render Geometry/Backfacing - Shader Editor.Mar 3 2019, 10:53 PM

@Jeroen Bakker (jbakker) can you take a look at this? I'm guessing this is OpenCL related.

Sebastian Parborg (zeddb) triaged this task as Normal priority.Mar 4 2019, 2:29 PM
Jeroen Bakker (jbakker) raised the priority of this task from Normal to Confirmed, Medium.Mar 14 2019, 8:53 AM

In foreground rendering it seems to be correct. Only fails when in background rendering.

Does not seem to be related to transparency. Using emision shaders also shows the problem.
Might be a mismatch of shader node groups in svm.h will research