Page MenuHome

Shader recalc and scene rerender after just adding node (shader wasn`t modified)
Closed, ArchivedPublic

Description

2.80 (sub 45), ae977d13f8e9, 2019-03-03 00:01

Adding new nodes during preview render causes crashes sometimes but I can`t reproduce it any time.

Preview should not rerender if I just tossing nodes to editor without connecting them to output branch.

Details

Type
Bug

Event Timeline

I fear Blender does not handle updates at this granularity.. Did this ever work?

Assigning to @Brecht Van Lommel (brecht), feel free to close if this is just a limitation.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Mar 4 2019, 12:48 PM

Does it crash if you are using CPU and not GPU?

We need exact steps to reproduce the crash, otherwise nothing we can investigate here.

Re-rendering is not a bug.

@Vyacheslav (hitrpr), I noticed you reported quite a few bugs, please always use the bug reporting template and provide all the requested information:
https://developer.blender.org/maniphest/task/edit/form/1/

@Brecht Van Lommel (brecht)
Yeah, bugs everyday :)
I am trying to not overhaul with unnecessary info.

And in this case Blender do work with no changes in scene. May be it is not a bug but behavior that very bad for efficiency

Vyacheslav (hitrpr) added a comment.EditedMar 5 2019, 7:35 PM

@Sebastian Parborg (zeddb) it is not about crashing, it is about regression (ppl call it regression bug)

2.79 works okay in this case and updates only when shader changes:

As @Brecht Van Lommel (brecht) stated, re-rendering is not a bug. So unless you can find any steps to reproduce the crash, there is not much we can do here.

Vyacheslav (hitrpr) added a comment.EditedMar 6 2019, 4:44 PM

@Sebastian Parborg (zeddb)
Can I dump crashlog somehow? I tried to find logs and found nothing.
Crashes are often, so may be I can collect info

And what about regression?

Does it crash if you are using CPU and not GPU?

@zeddbb Crashes was with GPU.
Now I can`t reproduce. It seems problem was with video-drivers and with GPU frequency/voltage jumps (I decreased maximum limit a little with afterburner).
Thanks for help. And what about regression? 2.79 do not render each time I add node as you can see on the video. But 2.8 does this useless work.

Sebastian Parborg (zeddb) closed this task as Archived.Mar 7 2019, 10:45 AM

@Brecht Van Lommel (brecht) is the cycles developer and as he stated, re-rendering is not a bug so there is nothing left to do here.

@Sebastian Parborg (zeddb)

I agree, that it is not a bug. But loss of efficiency since 2.79.
How and where can I report it?