Page MenuHome

Eevee does not support object picker in Object output of Texture Coordinate node
Closed, InvalidPublic

Description

Operating system: Windows 10
Graphics card: GTX1080Ti

Blender Version
Broken: 2.8 Latest master
Worked: Probably never

Short description of error
Eevee does not support object picker in Object output of Texture Coordinate node

Exact steps for others to reproduce the error
1, Select default cube, switch to lookdev mode and create a new material
2, Add some Image Texture to the Base Color slot of the material
3, Add Texture Coordinate node and feed its Object output into Image Texture Vector input
4, Notice the mapping works
6, Create a new empty object and select it in the Texture Coordinate Object picker
7, Rotate the empty object, and observe it has no effect on the texture mapping
8, Switch viewport to rendered mode and switch renderer to Cycles
9, Rotate the empty object and notice it affects the mapping

Result: When using "Object" output of Texture Coordinate node with Eevee, the Object picker at the bottom of the node does not work.

Expected: When using "Object" output of Texture Coordinate node with Eevee, the object picker works correctly, the same way it does in Cycles.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

This is a known limitation and not a bug: https://docs.blender.org/manual/en/dev/render/eevee/materials/nodes_support.html
From Dupli and coordinate from custom Object is not supported.