Page MenuHome

Rendering simple geometry corrupts with greasepencil layer
Closed, ResolvedPublic

Description

Windows 10
Radeon Vega 64

Broken: 2.80, 59f30e9390d4
Worked: 2.80, ae977d13f8e9

Rendering simple primitive geometry corrupts with greasepencil layer

Create simple building geometry for background, create greasepencil animation in front of geometry. animate camera move to follow GP animation.
Render output animation renders first couple of frames correctly then geometry flashes to white (no shader?). GP object renders correctly.

If I remove the GP object the geometry renders correctly.

If I use 'Viewport render animation' (while still in camera view) GP object and geometry render correctly.

Event Timeline

I cannot reproduce on Windows 10 RTX2080TI

Tom Nelson (tomnel) closed this task as Invalid.Mar 7 2019, 9:13 AM
Tom Nelson (tomnel) claimed this task.

Must be an OpenCL thing or something with my system. Strange because an older build works fine.
Thanks for looking!

Tom Nelson (tomnel) reopened this task as Open.EditedMar 10 2019, 4:27 AM

Maybe this is something for Jeroen Bakker (jbakker) to look at as this is still happening in current builds. but oddly not the current buildbot.

Now it just goes black

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

I can confirm this on my 290x (Linux, mesa git drivers). Only the first frame has the correct shading, in the rest the background objects are white.
I do not have OpenCL so this is not OpenCL related.

@Clément Foucault (fclem) can you reproduce this?

I cannot reproduce it either. I'm not sure about what could cause this.

Can you try to reproduce from scratch?

Tom Nelson (tomnel) closed this task as Archived.EditedMar 11 2019, 9:46 PM

I will try to do another scene soon, meanwhile I will close this as the latest builds are no longer doing this. If it pops up again I will reopen.

Thanks!

I can still reproduce this on my end with the latest blender git version.

@Clément Foucault (fclem) I bisected and found the commit that broke it for me:
rB798d2cadc307c8b53d111f86c66ace835dd4db49

Is there anything that you want me to do as you can't seem to reproduce this yourself?

Ok I can reproduce (I misread the repro steps) I'll take a look at it tomorrow.