Page MenuHome

Parent relationships not kept when duplicating collections (linked only)
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro (64 bits)
Graphics card: 2x Nvidia 1080 GTX

Blender Version
Broken: 2.8, 18e5540a48b6, 2018-06-02
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
Objects with parents in duplicate linked collections keep the original parents, instead of the newly duplicated object.

Exact steps for others to reproduce the error

  • add a sphere to default scene
  • set sphere's parent to default cube
  • in the outliner, right click on "Collection", click on duplicate collection
  • move duplicated cube (sphere follows as the cube expected)
  • in the outliner, right click on "Collection", click on duplicate linked
  • move duplicate linked cube (sphere does not follow the cube as expected - check the sphere's parent, it's still the default cube)
NOTE: If you select the objects and then duplicate them, the issue doesn't happen. It only happens when duplicating the collection.

Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) closed this task as Resolved.
Sebastian Parborg (zeddb) claimed this task.

I can not reproduce this so I'm guessing this is a duplicate of T62213 and has been fixed in todays build.