Page MenuHome

Reflection cubemap doesn't bake from objects, displayed as box.
Closed, ResolvedPublic

Description

System Information
Operating system: ubuntu 18.04
Graphics card: GTX 1070 driver: 390.116

Blender Version
Broken: March 13, 01:20:20 - bf9904ec8018

Short description of error
Reflection cubemap doesn't bake from objects, displayed as box.

Exact steps for others to reproduce the error

  1. Open the file, change the viewport to the render mode.

  1. You will see something like this, the cubemap is baked and contain reflection from the object displayed as box (LightDome.F.004):

  1. Delete a hte cubemap and bake it again. No reflections from the object displayed as box:

  1. Set the LightDome.F.004 object display as texture and rebake cubemap:

It is looks like cubemap can't bake from hidden objects, but it's not true, because it can bake it from objects that are hidden in viewport.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.Mar 13 2019, 4:44 PM

@Clément Foucault (fclem) is the baking supposed to be affected by the objects display type?

Hello.
I suppose many of the reports that have been linked to this other report, have been fixed with this commit:
https://developer.blender.org/D4643

But I'm not sure if the user who opened this particular report thinks that the problem is currently fixed in new 2.8 builds. I can not reproduce the problem with .blend file here.

Sebastian Parborg (zeddb) closed this task as Resolved.Apr 9 2019, 8:34 PM

Right, it seems like the result is now the same regardless of the viewport display mode of the dome.