Page MenuHome

Puzzling keymap descriptions
Closed, ArchivedPublic

Description

System Information
Operating system: Win7, 64-Bit
Graphics card: Nvidia GTX750

Blender Version
Broken: 2.80, 6fd11a21f5c5, master, 2019-03-10

Short description of error
I've been checking the Keymap section and had difficulty to understand some descriptions.

Example 1
(De)select All is used 4 times with A, Alt-A, Ctrl I and dbl-A

This is not correct, I was expecting something more like
Select all --> A
Deselect all --> Alt-A
Invert selection --> Ctrl I
Deselect all --> dbl-A

This is only shown in the Action part, when clicking on each small triangle at the left to open further explanation.

Example 2
Similar thing with Hide and Unhide Objects

Hide Objects is stated twice with keyboard shortcuts H and Shift H.
This is also not correct and puzzles users trying to understand the Keymaps.

Users would easily understand:

Hide Objects --> H
Hide unselected Objects --> Shift H
Unhide all Objects --> Alt H

But here, there is no Action information like on the (De)select section. Instead, there is only a clickable text called Unselected.

Example 3
Delete is described with X, Shift X, Delete and Shift Delete
Especially the Shift versions confused me.

Delete from current scene --> X
Delete from all scenes --> Shift X
Delete without confirmation --> Delete
Delete without confirmation from all scenes--> Shift Delete


I'd be glad to help to rename the descriptions :)

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

While it would be good to improve this, it's not a bug.

We have operators that can perform multiple actions, and those operators have only one name. A system to change the operator name depending on the setting could be good, but is outside the scope of the bug tracker.