Page MenuHome

Paste Normal Vectors
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Nvidia 1070

Blender Version
Broken: (example: 2.80, 18e5540a48b6, master, 2019-03-06,
Worked: (optional)

When I mark an edge as sharp Or split edge normals, It should remember that when I paste custom normal direction on selected face?

Exact steps for others to reproduce the error
Bevel one edge on the cube, with two segments. Select all edges as sharp. Select top face, go to mesh - normals - copy. select top beveled face ( The one slighty tilted) go to mesh - normals - paste. Do the same steps for the one in the bottom. If you have edge normal in overlays you will se that the copy paste tool does not respect the mark as sharp. And because of that I cant push normals in any direction as i want.

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

I can confirm that it seems like the paste function also overwrites the sharp tags.

Bastien Montagne (mont29) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Mar 18 2019, 5:02 PM

I do not see any issue here? Sharp edge status is preserved afaics, since you are applying the adjacent face's normal, obviously the edge in-between both of those face will look smooth, since both faces now have the same normal…

Also Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc. Would be much simpler to understand exactly what you mean with a .blend file…

Sorry if I did not report the template correct! Will do better next time!

Back to the bug,

When you mark a sharp edge/Normal split I suppose that the normals are split and I can manipulate them separately. But when I try to force the normals with copy and paste they move as one united. This happens:

I suppose this is the way to force normals in blender, I can't see why this does not work, or how you are supposed to do it otherwise?

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Confirmed, Medium.Mar 18 2019, 8:44 PM

Would have been even simpler (and quicker for us to reproduce) with a .blend file…

Now I can see the issue, looks like copy/paste is not taking into account selection modes as it should… will have a look.