Page MenuHome

Resizing Blender window on macOS causes artifacts (Red banding)
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-18.5.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon RX 580 OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.8.38

Blender Version
Broken: version: 2.80 (sub 51), branch: blender2.7, commit date: 2019-03-21 23:13, hash: rB1ae6aaad43ad
Worked: (optional)

Short description of error
When macOS is using graphics acceleration for the Blender window (in my case an eGPU Radeon RX 580), any resizing of the blender window causes large red bands to appear. The Blender UI does not adapt to the new window size and so it becomes unusable with some of the menus hidden. (please see screenshots)

Screenshot 1 - Window Zoomed (default appearance when opening)

Screenshot 2 - Window Resized by dragging corners

Screenshot 3 - Window full screen mode (usually how I use Blender on macOS)

Exact steps for others to reproduce the error
Simply resize the window on macOS while having GPU enabled for the Blender app. For what it's worth, this is the macOS system setting that enables graphics acceleration:

  • This has happened before on Blender builds. I noticed it in early beta builds (1 or 2 months ago) but it was fixed. I'm only reporting now since it hasn't been fixed in the last week+ of builds.

Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

No, cannot reproduce it here. Maybe it only happens with an eGPU, or these specific GPU drivers?

For what it’s worth, I’ve tested with two eGPUs: Radeon RX 580 (8 GB) and Vega 64 (8 GB). Issue behaves the same.

Probably only appears for eGPUs, but like I mentioned, this seems like a regression of old behavior. (Not sure if the fault lies on the Apple side for a new macOS update or a change in blender code though)

This is now fixed for me with the latest 2.8 daily build. I did update macOS to the latest dev version so it's possible that fixed it on the platform side, not sure.

Using eGPU acceleration and resizing the window shows no artifacts and behaves as intended.

Sebastian Parborg (zeddb) closed this task as Resolved.Apr 2 2019, 1:28 AM
Sebastian Parborg (zeddb) claimed this task.