Page MenuHome

Rigid Body Is Disabled When A New Workspace Is Added
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 64 bit
Graphics card: Nvidia GTX 750 Ti

Blender Version
Broken: (2.80, 79f67acccb36, blender2.7, 2019-03-24)

Short description of error
When adding a new workspace (rather than duplicating), all objects lose their rigid body properties.
Additionally, after re-enabling rigid body for an object, when duplicating it repeatedly, duplicates show up at the position where the last duplicate has been placed, rather than where the object is dragged to now.

Exact steps for others to reproduce the error
Default startup.

  1. Select the default cube.
  2. Enable "Rigid Body" in the physics tab in the properties panel.
  3. Play animation (default hotkey: space) for a few frames (e. g. 30), then stop at that frame.
  4. On the top, click the "+" to add a new workspace, and select "Video Editing > Video Editing". (Some others will work, too. Duplicate won't.)
  5. Go back to the "Layout" workspace.
  6. BUG: Observe that the default cube is not a rigid body anymore.

Furthermore, duplicates will appear in unexpected locations. To reproduce that as well, do these additional steps (after doing the steps above).

  1. Select the default cube and re-enable "Rigid Body". It jumps back to where it was in the simulation.
  2. Duplicate it with Ctrl+D and drag it somewhere, then click to confirm. It will appear in the origin, instead of the place it was dragged to.
  3. Duplicate with Ctrl+D again. The duplicate will now appear in the place you dragged to in the previous step.

I would expect it to appear in the place where it is dragged to immediately. Where the previous duplicate has been placed should have nothing to do with where the next one is placed.