Page MenuHome

UV seams visible with displacement texture
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.16299 64 Bits
Graphics card: GeForce GTX 1060 3GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 416.34

Blender Version
Broken: version: 2.80 (sub 53), branch: blender2.7, commit date: 2019-03-31 21:52, hash: rBb936d7b16c62
Worked: (optional)

Short description of error
The attached file was produced starting with a blank displacement texture then flood-filled with white in texture paint mode. The UV seams are visible in Eevee. They are visible in cycles render preview for the first few samples before fading away. This problem seems limited to the displacement texture. I did the same thing for the base colour, and no seams are visible.

Exact steps for others to reproduce the error
See problem in attached file. Sphere should be a completely smooth ball

Details

Type
Bug

Event Timeline

William Reynish (billreynish) closed this task as Invalid.

This happens just because the texture paint bleeding was too low.

If you properly fill the actual texture, you don't see any seams:

That was obviously just an example. Filling the entire texture with white is not a practical solution. The white sections are entirely within the UV bounds. If the texture paint bleeding is too low to prevent such artifacting, isn’t that at the very least a texture paint bug?

No, I don't think it's a bug. It's an inherent issue with mipmapping and bleeding.

You might want to increase the bleed here, from 2px to perhaps 8 or so:

It could have a higher default, but that can cause issues when UI islands are too close.