Page MenuHome

Eevee Texture Time Out Causes Freezing
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 770/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.35

Blender Version
Broken: version: 2.80 (sub 54), branch: master, commit date: 2019-04-05 14:31, hash: rBd140e597a6a8
Worked: (optional)

Description of error
At seemingly random intervals, while running Eevee, Blender will completely freeze for several seconds, before resuming without any kind of acknowledgement of the freeze.
The interval is actually related to [Preferences >> System >> Memory & Limits] Texture Time Out and Garbage Collection Rate.

If you lower both of these to 1, if Eevee is running, Blender will freeze forever.
If you set them to around 5-10, the freezes will be frequent but you'll have a moment to stop something from in Blender.
If you set Texture Time Out to 0, this freeze stops.

It appears to be a hardware/performance thing though, because if I set the GL Texture Limit to 128, the freezes still occur at 1 & 1, just not forever (breaking Blender)

Instructions to reproduce
If you load this file and start Eevee, everything will run like normal.
However, if you drop the Texture Time Out and Garbage Collection Rate values, you should see the freezing problem.


This file contains a low-poly character with multiple materials and packed image textures.
The character is nude but they're so decimated, I don't think it matters.

I'm disabling Texture Time Out, to bypass this issue, since I don't think I care about what it does.

Event Timeline

Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

This is not really a bug. If you set the value too low then blender will freeze because it is constantly loading and unloading textures into memory.

The bug isn't that setting it low will break Blender.
The bug is that by default this is enabled, and Blender will randomly freeze without any notification of what's going on.

Sebastian Parborg (zeddb) triaged this task as Normal priority.

Same issue here, I get regular freezes in eevee and lookdev on win 10 and rc1.
This behavior is unchanged for round about 4 months now.
Set the timeout to 0 and the freezes are gone. :)

What does the timeout do exactly and is it necessary?