Page MenuHome

Mask display not updating correctly
Closed, ResolvedPublic

Description

System Information
Windows 7
Titan X

Blender Version
Broken: 2.80, APr 7 build
Worked: 2.79

Short description of error
Once a mask is drawn, and a key frame set, I set another keyframe a few frames later. As I step through the frame sequence (PNG files), the mask does not interpolate correctly. It's position does not line up where it should be.

Exact steps for others to reproduce the error
Draw and animate a mask, putting keyframes 3 or 4 frames apart. As you go between them to adjust, the mask does not update/display correctly. I've attached the file it happened to me on, but cannot include the frame sequence because it's an unreleased client project.

Details

Type
Bug

Event Timeline

Sebastian Koenig (sebastian_k) triaged this task as Confirmed, Medium priority.

Yep, can confirm that. It's really weird. Sometimes mask points move different than the others, sometimes the vector handles behave inconsitently, resulting in a deformed mask. I was able to reproduce it best when changing the selection status (all, none, single points).

Brecht Van Lommel (brecht) raised the priority of this task from Confirmed, Medium to Needs Triage by Developer.

Better leave triaging to developers, otherwise it can slip through and not get assigned to the right developer or handled with the right priority.

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

@Richard Antalik (ISS) feel free to reassign if this is not for you.

Sergey Sharybin (sergey) closed this task as Resolved.Jun 5 2019, 2:58 PM

This issue is resolved by rBfec9615ea06.
Thanks for the report, closing.