Page MenuHome

Sometimes Blender 2.8 scale and dimension values update automatically, sometimes only mouse over
Closed, ArchivedPublic

Description

System Information
Operating system: windows 10
Graphics card: geforce gtx 960

Blender Version
Broken: (example: 2.80, edbf15d3c044, master, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
The value that represents the size of the current selected object doesn't always update automatically when you animate the object scale

Exact steps for others to reproduce the error
Create object, for example spehere and animate it to scale bigger during the whole timeline. It might be that first when you create the animation the object scale will animate also with the object scaling, but then later it stops updating and you have to move mouse around the fields to see the current size of the object.

I believe this has been an issue also in older blender versions (i didn't test tho), so it might be a very old bug.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

Right, it seems like the UI doesn't refresh:

@Sergey Sharybin (sergey) feel free to reassign if this is not for you.

Sergey Sharybin (sergey) closed this task as Archived.Jun 5 2019, 2:38 PM

This isn't really a bug, but a side effect of an optimization. The issue here is that properties redraw is not very cheap: it takes both GPU time but also CPU time to check whether property is animated, whether current frame is one of keyframes of that property and so on (to properly color the background).

How Blender works here is that the editor or a region from where the playback was started will always be refreshed during playback. This is be cause it's considered as an area of interest so to speak: if you're tweaking something there you're likely be interested in all realtime updates. On top of that editors matching mask from Playback menu will also be updated. All the rest editors stays untouched and only way to trigger their redraw is to hover the mouse.

If you want all properties to be refreshed you need to enable "Property Editors" in the Playback back menu.

Thanks for the report, but it's not a bug.