Page MenuHome

Imported GLTF files with keyframes creates strange graphs until manually updated
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1080 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.67

Blender Version
Broken: version: 2.80 (sub 54), branch: master, commit date: 2019-04-08 19:21, hash: rBdf26f28835fb

Short description of error
Not sure if this is an exporter/importer error or Blender is missing some kind of refresh on API created keyframes

Exact steps for others to reproduce the error
Delete all objects in the default Blender scene
Import the following GLB file using the default GLTF importer


Select the body object

Open up a Graph Editor. You will see the Golden Gate before your eyes because every handle is in the 0,0 coordinate

Select all keyframes, press G and then Esc
Blender recalcs the auto handles and everything returns to normal

Details

Type
Bug

Event Timeline

Julien DUROURE (julien) triaged this task as Normal priority.Apr 11 2019, 8:43 AM

This will be manage on upstream issue tracker:
https://github.com/KhronosGroup/glTF-Blender-IO/issues/419

This is probably linked to tangent of CUBISPLINE interpolation, that is not yet implemented

This will be manage on upstream issue tracker:
https://github.com/KhronosGroup/glTF-Blender-IO/issues/419

155 open issues for the GLTF addon alone... ouch. I guess it will take a few more years before that one is actually usable :)

@Ludvik Koutny (rawalanche), that tracker is also used for tracking enhancements. And please stay on topic, this bug tracker is not a forum.

I see the problem, but arent auto keyframes never supposed to do that? Should blender allow for that mess to begin with when setting autohandles from BPY?

Julien DUROURE (julien) closed this task as Resolved.Apr 14 2019, 8:44 AM

This is now fixed in 5fdd91c09edf7c5a4794a3de4fbb1a7603d609f0

Note that I only refresh auto handle data of fcurves. Tangents from gltf file are not managed yet, still TODO